Back to overview
Downtime
Platform is experiencing an outage and is unavailable
Mar 14, 2026 at 2:17am UTC
Affected services
Main platform
Authentication service
API
Resolved
Mar 14, 2026 at 2:30am UTC
The issue has been resolved
Affected services
Created
Mar 14, 2026 at 2:17am UTC
The issue related to our internal services
Affected services