Back to overview
Downtime

Platform is down due to Cloudflare Network issue

Nov 18, 2025 at 11:36am UTC
Affected services
Main platform
Authentication service
API

Resolved
Nov 18, 2025 at 4:49pm UTC

Application is fully available.

Created
Nov 18, 2025 at 11:36am UTC

Aplication is down due to Cloudflare Network issue